Consistency handling null
values in MultiSelect List
and MultiSelect Hash
#156
-
Under the assumption, the jmespath playground at jmespath.org represents the canonical output for any expression, there appear to be some interesting inconsistencies. Either these are undocumented in the spec, or the spec isn't clear on how to handle these edge cases, or there are language-specific implementations that treat the following edge cases differently. Consider the following... what would you expect
// expression
`null` | [@]
// Should it be : [null]
// OR : null
// expression
`null` | {foo: @}
// Should it be : {"foo": null}
// OR : null |
Beta Was this translation helpful? Give feedback.
Replies: 1 comment
-
Hi @glenveegee We have answered this question and standardized this behaviour at JMESPath Community. We believe your second example should return You are right that this is not part of the compliance tests and some implementations may still be "broken". |
Beta Was this translation helpful? Give feedback.
Hi @glenveegee We have answered this question and standardized this behaviour at JMESPath Community.
We believe your second example should return
{"foo": null}
.You are right that this is not part of the compliance tests and some implementations may still be "broken".